Minor releases of Go can change `go fmt` which can break linting. Inconsistent formatting are just going to create annoying problems, so the Go compiler will be pinned to the latest patch of a specific minor rev. This should pick up security fixes without disrupting development. We can coordinate a move to a newer Go release.
3 lines
98 B
Nix
3 lines
98 B
Nix
with import <nixos-unstable> {};
|
|
runCommand "dummy" { buildInputs = [ go_1_18 gnumake gcc ]; } ""
|