1
0
mirror of https://github.com/asciinema/agg.git synced 2025-04-19 05:02:14 +03:00
agg/flake.nix
Yvan Sraka 56fee66e7b Fixes #48: unable to nix run
error: unable to execute '/nix/store/.../bin/agg-1.4.2': No such file or directory
2023-07-24 12:28:33 +02:00

26 lines
802 B
Nix

{
inputs = {
naersk.url = "github:nix-community/naersk/master";
nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, utils, naersk }:
utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs { inherit system; };
naersk-lib = pkgs.callPackage naersk { };
in {
defaultPackage = naersk-lib.buildPackage {
pname = "agg";
src = ./.;
};
defaultApp = utils.lib.mkApp { drv = self.defaultPackage."${system}"; };
devShell = with pkgs;
mkShell {
buildInputs =
[ cargo rustc rustfmt pre-commit rustPackages.clippy ];
RUST_SRC_PATH = rustPlatform.rustLibSrc;
};
});
}